Thursday, 5 March 2015

codeship error: ruby-2.0.0-p195 is not installed.



Recently, I get this error on codeship:


rvm use 2.0.0-p1950 min 1 sec
Warning! PATH is not properly set up, '/home/rof/.rvm/gems/ruby-2.1.2/bin' is not at first place, usually this is caused by shell initialization files - check them for 'PATH=...' entries, it might also help to re-add RVM to your dotfiles: 'rvm get stable --auto-dotfiles', to fix temporarily in this shell session run: 'rvm use ruby-2.1.2'. ruby-2.0.0-p195 is not installed. To install do: 'rvm install ruby-2.0.0-p195'





The first two lines of my setup commands are:

rvm use 2.0.0-p195

bundle install


It looks like they have ruby-2.0.0-p195 installed to all VMs before. And they have removed ruby-2.0.0-p195 and offer ruby-2.1.2 instead today.

A codeship doc for ruby version:

https://codeship.com/documentation/languages/ruby/


So all of our projects should change the setup command from "rvm use 2.0.0-p195" to "rvm use ruby-2.1.2"


Or use  .ruby-version file

No comments:

Post a comment