Monday, 20 July 2015

:app:prepareDebugAndroidTestDependenciesConflict with dependency 'com.android.support:support-annotations'. Resolved versions for app (22.2.1) and test app (22.2.0) differ.



:app:prepareDebugAndroidTestDependenciesConflict with dependency 'com.android.support:support-annotations'. Resolved versions for app (22.2.1) and test app (22.2.0) differ.


Recently i got this error: because my gradle file has this:


dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    compile 'com.android.support:support-v4:22.2.+'    
    compile 'com.android.support:appcompat-v7:22.+'




solution :


dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    compile 'com.android.support:support-v4:22.2.0'    
    compile 'com.android.support:appcompat-v7:22.2.0'

No comments:

Post a comment