Sunday, 18 October 2015

heroku error: gyp ERR! build error (nodejs)


gyp ERR! build error





The reason is, the latest node version is 4.x, my project used to work, because the node was: 0.12.7:




current node:




According to http://apmblog.dynatrace.com/2015/09/05/all-you-need-to-know-about-node-js-4-0/

io.js and node.js have decided to merge. and the version will become to 4.x

I think the merge makes gyp error.

we need wait....



Temperature solution: (fix node version.)

change this:

"engines": {
    "node": ">=0.10.0"
  },

To :

  "engines": {
    "node": "0.10.35"
  },























No comments:

Post a comment