Thursday, 29 October 2015

Mac EI captitan grunt serve error: You need to have Ruby and Sass installed and in your PATH for this task to work.

 Warning: Running "sass:server" (sass) task
    Warning: 
    You need to have Ruby and Sass installed and in your PATH for this task to work.
    More info: https://github.com/gruntjs/grunt-contrib-sass

     Use --force to continue.

solution:

You should have ruby, but you can run this to double check "ruby -v" 

next run "sass -v" to check do you have sass.

if you get this: "-bash: sass: command not found"

you can use this command to install: "sudo gem install -n /usr/local/bin sass" 

please note: if you use "sudo gem install sass" you will get this error:


ERROR:  While executing gem ... (Errno::EPERM)
    Operation not permitted - /usr/bin/sass






No comments:

Post a comment