Monday, 23 November 2015

Failed at the v8-debug@0.4.6 install script 'node-pre-gyp

I got this error when i am using yeoman to install angular-fullstack (and running npm install afterwards )

people said is it not gyp, it is inspector:

you can do this to fix npm install:


"grunt-node-inspector": "~0.2.0"
to
"grunt-node-inspector": ">=0.2.0",

https://github.com/node-inspector/v8-debug/issues/7


But after that my npm can be successfully ran, but it still have errors:




This is the key information:

"Agreeing to the Xcode/iOS license requires admin privileges, please re-run as root via sudo."

That because you upgrated your Xcode and you haven't open it and accept some agreements.

To fix this you need open your Xcode,  and click "accept"



http://stackoverflow.com/questions/26197347/agreeing-to-the-xcode-ios-license-requires-admin-privileges-please-re-run-as-r

https://github.com/DaftMonk/generator-angular-fullstack/issues/1350

No comments:

Post a comment