Saturday, 4 June 2016

ERROR: While executing gem ... (Errno::EPERM) Operation not permitted - /usr/bin/compass



I updated my Mac recently, and i can not compile one of my old project now:


So i have to reinstall my compass.

However, i got this error:

ERROR:  While executing gem ... (Errno::EPERM)

    Operation not permitted - /usr/bin/compass





Solution:

always make sure you updated your xcode to the latest version.
open your xcode, don't need to create any app, just open, if xcode asks you to agree or download anything, please agree.
sudo brew install ruby
sudo gem update --system
sudo gem install compass


if above command give you error, then try below:

sudo gem install -n /usr/local/bin sass

you will be ok if you see below error.




No comments:

Post a comment